Comment savoir si un moteur pas à pas est mort?

Comment savoir si un moteur pas à pas est mort?

Testeur de pilote pas à pas

mon choix d’option, remplacer les quatre fils par du fil flexible isolé au silicone, isolé avec de la gaine thermorétractable de la partie fixe du câble de l’extrudeuse qui se monte dans le boîtier einsy…

si la continuité du moteur est bonne, essayez d’intervertir la fiche du moteur X ou Y, sur la prise de l’extrudeuse, sur la carte einsy, et en utilisant les paramètres >move axis, e axis option, voyez si le pilote du moteur e va piloter le moteur X ou Y… s’il ne pilote pas l’autre moteur, l’einsy peut être défectueux

J’essaie de faire des suggestions sûres, vous devez comprendre le contexte et vous assurer que vous êtes heureux qu’elles soient sûres avant d’essayer d’appliquer mes suggestions, ce que vous faites, c’est VOTRE responsabilité. Localisation Halifax UK

Merci pour la réponse, j’ai essayé la première suggestion et maintenant le moteur pas à pas tourne à nouveau. Cependant, j’entends un bouchon (comme un clic) lorsque le filament descend, et l’extrusion est bizarre. Que puis-je faire ?

J’essaie de faire des suggestions sûres, vous devez comprendre le contexte et vous assurer qu’elles sont sûres avant d’essayer d’appliquer mes suggestions, ce que vous faites, c’est VOTRE responsabilité. Localisation Halifax UK

A4988 ne fonctionne pas

L’image ci-dessous est ce que je suis en train de tester. La puissance sur la droite est de 12v et la puissance sur la gauche est de 5v. STEP et DIR sont gérés par un arduino et 1a/1b/2a/2b est connecté à un NC17. J’ai eu ce travail au début avec les connexions et le code montré ci-dessous, mais maintenant les moteurs ne répondent pas.

  Music instrument shield arduino

Quel moteur pas à pas, quelles alimentations et quels dissipateurs thermiques utilisez-vous avec vos pilotes ? Idéalement, veuillez poster les fiches techniques de ces éléments ou les liens vers les sites où vous les avez obtenus. A quoi réglez vous VREF lorsque vous testez vos pilotes ?

Nous n’avons jamais fabriqué de supports A4988 ou A4983 avec des PCB rouges, donc ces quatre drivers ne sont pas les nôtres, donc nous ne pouvons pas offrir de conseils de dépannage spécifiques pour eux puisqu’ils sont probablement différents des nôtres.

Les cartes vertes ressemblent aux nôtres, mais pour être sûr, pouvez-vous poster une photo de l’arrière des cartes vertes montrant les étiquettes sérigraphiées ? Vous souvenez-vous si ces chauffeurs ont déjà travaillé pour vous ? Étant donné leur âge, pouvez-vous également essayer de retirer les dissipateurs thermiques afin de pouvoir lire l’étiquette sur le circuit intégré pour déterminer s’il s’agit de pilotes A4983 ou A4988 ?

Comment vérifier si l’a4988 fonctionne ou non ?

Bonjour, J’utilise une imprimante 3d de type rostock de Geeetech avec des moteurs pas à pas et des courroies. Il semblerait que l’un de mes moteurs soit mort et je ne sais pas pourquoi. J’ai cherché en ligne des options de dépannage mais j’ai eu du mal à trouver quelque chose pour ce que j’ai exactement. Je me demande si quelqu’un a des conseils à me donner.

Le moteur est un moteur de 1,8 degré et lorsqu’il est branché, il ne répond tout simplement pas aux commandes. Je l’ai retiré de l’imprimante et il semblait rigide ou peut-être bloqué, alors j’ai fait la chose logique… je l’ai démonté. Rien à l’intérieur ne semblait anormal ou défectueux, mais je n’ai jamais vu l’intérieur d’un moteur en fonctionnement, donc je n’ai pas vraiment de base. Je l’ai remonté et il semble ne plus être bloqué ou rigide mais il ne répond toujours pas aux commandes.

  Comment shunter un radar de recul?

Je suppose qu’il y a quelque chose d’anormal et qu’il ne reçoit plus de signal puisqu’il fonctionne sur la base d’impulsions de tension et d’un aimant. J’ai donc vérifié et retéléchargé mon code sur lequel l’arduino fonctionne et toujours pas de réponse. Je pense que soit mon moteur, soit mon câble est mort.

Comment savoir si un pilote de pas à pas est défectueux

Je vais supposer qu’il s’est peut-être cassé lors de son dernier travail catastrophique. La table a tellement basculé que cela a déconnecté un ou deux des moteurs du RAMBo 1.4. J’ai tiré les leçons de cet échec, alors ne nous y attardons pas…

J’ai essayé tous les moteurs dans toutes les prises, et j’ai vérifié au moins un brochage de moteur du moteur au connecteur pour vérifier la continuité de l’extension. J’ai seulement essayé de déplacer les moteurs à partir de l’écran LCD. J’ai également vérifié le fusible.

Aucun des canaux ne fonctionne, donc je ne pense pas que le câblage en série fonctionnerait. Comment puis-je vérifier la sortie du signal pour voir si je peux utiliser un pilote externe ? Dans le même ordre d’idée, est-ce que les doubles endstops fonctionneront toujours avec un pilote externe ? Si ce n’est pas le cas, je vais probablement commander un Archim.